12.2 SP1 integration with Autotask- user requirements

Article Number: 000070116

Last Modified: Thu Mar 12 14:21:57 GMT 2020

Description

  • We are updating to accommodate the new v1.6 of Autotask's API to better integrate with N-central.  This will allow for better integration in the future and improved functionality overall.

 

  • Partners may come across the following message:

"API User (API Only) security level needs to be apllied to the account used."

Environment

  • SolarWinds N-central 12.2 SP1 and above

Solution

The Integration Account used for Autotask must have the Security Level set to API User (system).  The integration vendor setting must be set to SolarWinds N-central (On-Premise).

API user requirements

The user, whose credentials are used for integration, has to meet the following conditions:

  • Security Level: "API User (system)"
  • API Tracking Identifier:
    • "Solarwinds - N-central  (on premise)" when on premise server or
    • "Solarwinds - N-central" if on an NCOD server.

Both of those accounts can be set in Resource Management section under Security tab in Autotask UI

 

API User (API-only) security level details

Following rules apply to the API-only User used for integration: 

  • API-only users must be created and managed from Autotask UI
  • API-only users are not permitted to login to Autotask UI
  • API-only users cannot be assigned any tickets or tasks
  • API-only users are allowed to created entities via API but they cannot own or get associated with them

 

Did this article help you?

Rate this article

Share

Recommended Content